News:

 

Topic: Interface is out-of-whack NVil -Mar 12 2024  (Read 773 times)

0 Members and 1 Guest are viewing this topic.

  • Posts: 57
  • Edge
    • 3ddmd
May 09, 2024, 07:27:19 pm
The top menu is partially covered and the side items, namely the Smart Tips menu,  are all smashed together - so much so, that some buttons are no longer interactive. It appears to be fairly consistent on three of my PC's. And it appears NVil is no longer HDPI aware anymore? The buttons and text are super tiny. Anyone else notice?  ???



« Last Edit: May 09, 2024, 07:40:17 pm by chikega »

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
May 09, 2024, 10:35:42 pm
What is your screen resolution?
If it is higher than HD, Do this

1. Right click Nvil.exe icon and choose "Properties" to bring up the app properties setting dialog.
2. Click and open the "Compatability" tab.
3. Click the "Change high DPI settings" button to open the DPI option window.
4. Check the "Override high DPI..." option.
5. In the drop-down list box, choose "System".
6. Click "OK" button to exit to properties dialog.
7. Click "Apply" button.
8. Click "OK" button.
9. Open Nvil and see if there is any difference. If not, restart PC and try open Nvil again.

  • No avatar
  • Posts: 14
  • Vertex
May 09, 2024, 11:25:00 pm
I noticed (and didn't report sorry) a similar thing happen as well.

The menus and dialog was inconsistent when I was using windows display setting "Scale 125%" (Right-click your desktop -> Display Settings -> Scale and Layout -> Scale).

For a CAD program I was using, I needed to drop it to 100% as they were handling the retina style re-scaling on their end. I wound up using NVIL again during this time and noticed the UI issues were resolved as well. I can fit loads of stuff on my screen now and my clock is super tiny, but it works kind of.

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
May 09, 2024, 11:39:48 pm
There are some GUI scale options in Nvil
Help > Contents > User Interface > Options and UI Customization > GUI Scale(Down at bottom of the page).

  • Posts: 57
  • Edge
    • 3ddmd
May 10, 2024, 09:06:03 pm
That did the trick. Thank you so much! :) I'm running at 3840 x 2160 (150% Scaling) on two of my PC Desktops and 1920 x 1080 on a laptop.
 
For those that also have the Steam version, will want to go to:
Code: [Select]
C:\Program Files (x86)\Steam\steamapps\common\NvilThe NVil icon that Steam produces on the Desktop is an alias to this directory.
« Last Edit: May 10, 2024, 09:12:09 pm by chikega »