News:

 

Topic: Mesh display - Edge connections  (Read 540 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 71
  • Edge
October 08, 2021, 09:36:35 am
Hello, would it be possible to have mesh display clean and without artifacts even if edges are not completely connected?

For example here you see clean mesh



But if you disconnect the edge it creates artifact



The purpose of this feature would be possibility of modeling without connecting all the edges and having multiple bevels with quite clean mesh that would allow for quick and easy modifications later down the road. I know Blender already has this by default, I thought it would be really awesome to have it here as well especially for hardsurface poly modeling.



And in case you export it out for rendering in other software you can always triangulate the mesh.

  • No avatar
  • Posts: 3666
  • Developer
  • Administrator
  • Polygon

  • No avatar
  • Posts: 71
  • Edge
October 18, 2021, 04:25:18 pm
So far working great IStonia! Thank you. Will let you know if anything weird pops up

  • No avatar
  • Posts: 71
  • Edge
October 20, 2021, 10:12:46 am
Hello - I am experiencing much much longer load times of OBJ files or when I duplicate dense objects (feels like x5 at least) - not sure if this came after this update or any other new features in versions between - my current working version that works smooth is 2020-Jun-23 (i have few versions and features to catch up :D!)

Edit: i tested with latest 2021-Sep-20 and works smooth so it must be something with this new feature
« Last Edit: October 20, 2021, 10:19:11 am by thor6136 »

  • No avatar
  • Posts: 3666
  • Developer
  • Administrator
  • Polygon
October 20, 2021, 12:27:46 pm
Try this and see if it's better
http://www.digitalfossils.com/Download/NVil-Oct-20-21.rar

Does the model have many Ngons(polygons which edge number is more than 4)?

-------

Edit: Also check with this version, http://www.digitalfossils.com/Download/NVil-Oct-21-21.rar
« Last Edit: October 20, 2021, 09:14:53 pm by IStonia »

  • No avatar
  • Posts: 71
  • Edge
October 24, 2021, 08:42:09 am
2021-Oct-20 version works good and smooth! Thank you. (less then 10 seconds)
2021-Oct-21 still has long load time (3minutes)

FYI there are no n-gons in the model, cheers!

  • No avatar
  • Posts: 71
  • Edge
October 25, 2021, 10:13:51 am
I found new issue - when I select a face the selection display gets a bit weird even though the face looks good without selection


  • No avatar
  • Posts: 3666
  • Developer
  • Administrator
  • Polygon
October 25, 2021, 01:15:59 pm
Can you send me the model, info@digitalfossils.com.

  • No avatar
  • Posts: 3666
  • Developer
  • Administrator
  • Polygon

  • No avatar
  • Posts: 71
  • Edge
October 25, 2021, 07:40:06 pm
It got a little bit better i think (seems to be less 'lines') but there is still an issue, i sent you the model to the email

« Last Edit: October 25, 2021, 07:42:02 pm by thor6136 »

  • No avatar
  • Posts: 3666
  • Developer
  • Administrator
  • Polygon

  • No avatar
  • Posts: 71
  • Edge
October 30, 2021, 11:42:40 am
Works good, thank you sir!