News:

 

Topic: How to handle lots of polygons?  (Read 3719 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 10
  • Vertex
September 25, 2020, 06:27:23 pm
Hello! I mostly plan on using Nvil for retopology. I tried to import a 250mb .obj with about 12 million polygons, took a while to import and viewport was pretty laggy.

Is there any settings that I can turn on or off so I can handle more polys in Nvil?

Thanks!

Specs:
32 gb ram ddr4
rtx 2070s
amd 3700x

  • No avatar
  • Posts: 176
  • Spline
    • White-creatures
September 25, 2020, 10:10:14 pm
Hi,

12 million polygon is really big.. for my pc (16 gb ram, geforce gtx 1060 and Intel i7-4770), a pretty old.. more than 7 years PC i guess.. I can barely handle even 1 million i think, I always use zbrush to decimate it to about 0.1 or 0.2 million before i bring into Nvil to retopo... so I think before any settings, you can try reduce the polygons first if possible.

  • No avatar
  • Posts: 10
  • Vertex
September 25, 2020, 11:15:28 pm
Thanks! Sounds like a good option, although if there are ways to optimize viewport performance I would like to hear them as well!

I'm preparing a custom config and I want to get things nice before releasing it :)

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
September 25, 2020, 11:37:21 pm
What version are you using? Can you provide a snapshot or a short video?

Check this and see if that helps.
Help > Contents > User Interface > Viewport Performance.

  • No avatar
  • Posts: 10
  • Vertex
September 25, 2020, 11:52:17 pm
Thanks, Sonia! Will check these.

I'm using Nvil from Steam, so the latest Steam version of Nvil

  • No avatar
  • Posts: 10
  • Vertex
September 26, 2020, 12:22:27 am
What version are you using? Can you provide a snapshot or a short video?

Check this and see if that helps.
Help > Contents > User Interface > Viewport Performance.

Hmm, this is weird, panning and rotating seems to work fine. The lag comes when I zoom, not only that, but only when I zoom with the mouse wheel, if I zoom with alt + right click it doesn't lag.

what could be the cause of this?

https://youtu.be/lF1s5huFFWM
« Last Edit: September 26, 2020, 12:28:18 am by simonsanchezart »

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
September 26, 2020, 12:42:14 am
I will see if I can find a way to improve it.

For now, you can do these to avoid the problem.
1. Select the HP object in scene.
2. Open the Draw Mesh tool, Geometry > Create > Draw Mesh.
3. Click the "Reference" Button in the Draw Mesh tool UI.
4. Click the "OK" Button in the popup dialog.

Now the HP object is frozen which should solve the problem.

  • No avatar
  • Posts: 10
  • Vertex
September 26, 2020, 12:59:13 am
I will see if I can find a way to improve it.

For now, you can do these to avoid the problem.
1. Select the HP object in scene.
2. Open the Draw Mesh tool, Geometry > Create > Draw Mesh.
3. Click the "Reference" Button in the Draw Mesh tool UI.
4. Click the "OK" Button in the popup dialog.

Now the HP object is frozen which should solve the problem.

Thanks a lot! The objects in the video were already frozen and as retopo reference.

Out of topic but where are the matcaps stored in Nvil? I want to bundle them with the user settings to share my config.

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
September 26, 2020, 01:15:33 am
There is no default matcaps contents in Nvil. You need to create your own.
If you want other users be able to share your matcaps, you can put the matcaps in a folder with name "NVilMatCaps" inside the Nvil installation folder. Then I can include the matcaps in new release versions.

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
September 26, 2020, 10:09:14 am
Thanks a lot! The objects in the video were already frozen and as retopo reference.

Try this and see if it is better.
http://www.digitalfossils.com/Download/NVil-Sep-26-20.rar

Edit: Make sure this option is unchecked, Edit > Preference > Options 2 > Snap to frozen object enabled.
« Last Edit: September 26, 2020, 11:28:42 am by IStonia »

  • No avatar
  • Posts: 10
  • Vertex
September 26, 2020, 02:48:22 pm
Thanks a lot! The objects in the video were already frozen and as retopo reference.

Try this and see if it is better.
http://www.digitalfossils.com/Download/NVil-Sep-26-20.rar

Edit: Make sure this option is unchecked, Edit > Preference > Options 2 > Snap to frozen object enabled.

Thanks, but didn't fixed it. Zooming with mouse wheel is still laggy, zooming with alt + right mouse button is smooth.

I do have 'Snap to frozen object' disable.

Other than that, I could not use that version myself because it ask for a registration key, I bought it from Steam so I don't have one.

Is it possible for example to make the scroll wheel use the same type of zoom that alt + right click uses? make it an option in preferences?

thanks a lot!

  • No avatar
  • Posts: 3716
  • Developer
  • Administrator
  • Polygon
September 26, 2020, 11:15:44 pm
Test this
http://www.digitalfossils.com/Download/NVil-Sep-27-20.rar

The steam version will be updated once it is fixed.

  • No avatar
  • Posts: 10
  • Vertex
September 26, 2020, 11:27:31 pm
Test this
http://www.digitalfossils.com/Download/NVil-Sep-27-20.rar

The steam version will be updated once it is fixed.

That works better! Thanks.