News:

 

Topic: Triangulate faces with edge direction based on distance from reference mesh  (Read 245 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 27
  • Vertex
January 25, 2019, 07:52:58 am
Hey,
I've been thinking it would be really useful to be able to intelligently triangulate face selections with the new edges direction based on how close it's center point is to to the reference mesh (along it's normal vector).
I find myself doing this operation manually (by eye) many times when retopologizing organic meshes so it would be a huge time saver for me to have this automated.
If this feature already exists I'd really appreciate someone pointing out how to find it.
« Last Edit: January 25, 2019, 07:58:14 am by haystax »
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 29, 2019, 08:55:53 am
Try this
http://www.digitalfossils.com/Download/NVil-Jan-29-19.rar

  * Polygon mode > Geometry > Rewind(Retopo). Set the selected or highlighted polygon's face winding so its faces will most close to the retopo reference object surface. If no selection or highlighted polygon, it will work on all visible polygons.
  * Polygon mode > Selection > Polygons Retopo-Rewindable. Select those polygons whose face winding are not optimized to close to retopo reference object surface.
  * When in retopo mode, if subobjects are created/welded/transformed/relaxed, the polygon face winding in the affected area will be optimized to best match the retopo reference object surface automatically.
 

  • No avatar
  • Posts: 27
  • Vertex
January 29, 2019, 08:37:51 pm
This is fantastic, a HUGE time saver!!! Thanks so much IStonia :D
I'm getting a bug in the new version, when loading existing scenes the materials in the viewport are unshaded and black. New objects I create in the same scene look fine.
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 29, 2019, 09:34:21 pm
It works fine on me. Can you send me your user setting files and a simple scene file which can produce the bug?

  • No avatar
  • Posts: 27
  • Vertex
January 29, 2019, 10:56:29 pm
Check your DMs
It only seems to happen in scenes where I've been retopologizing over a high res reference mesh, in these cases the reference mesh draws fine but the low res mesh is black.
Scenes that aren't using retopo are fine.
« Last Edit: January 29, 2019, 10:58:56 pm by haystax »
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 29, 2019, 11:03:44 pm
The scene file is too big for my pc memory.

Does it happen if your reference object is not that high in poly count?

  • No avatar
  • Posts: 27
  • Vertex
January 29, 2019, 11:14:54 pm
Ok, this only seems to happen on two of my most recent files. All of the others are fine.
Poly count doesn't appear to be related to the issue.
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 29, 2019, 11:22:57 pm
Seems like a bug somewhere. Can you reduce the model to only 10% of its current size so I can check it on my pc? Make sure the LP version still can produce the bug on your side.

Edit: I need the original file format, like obj/fbx, rather than vws file.
Edit: One question. Can you assign a material to it so it won't appear black?
« Last Edit: January 29, 2019, 11:38:44 pm by IStonia »

  • No avatar
  • Posts: 27
  • Vertex
January 30, 2019, 12:42:49 am
I'll DM you a link to the reduced version saved as .fbx
I can't apply any materials to the object that is appearing black.
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 30, 2019, 01:01:17 am
I can load it with your settings without any problem. It is brown. Right? I also can assign it to a different material.

Have tried load it to Nvil yourself? If it appears black on your side, please send me the vws file.

Edit: I have been able to load the temp.vws file you sent me previously. Also no problem on my side at all. Strange!
« Last Edit: January 30, 2019, 01:07:24 am by IStonia »

  • No avatar
  • Posts: 27
  • Vertex
January 30, 2019, 01:10:43 am
Hmm, weird.
There should be two objects, one red hat (the reference object) and one green hat (the retopo object).
The low poly hat that should be green is actually black and unshaded for me.
« Last Edit: January 30, 2019, 01:15:22 am by haystax »
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 30, 2019, 01:34:03 am
I know the problem now.

The values of the normals of the Object_Combined are all zero!

There two ways you can fix it.

1. Vertex mode > Geometry > Common Command n Tools > Normal > Click the "Compute Normals(All)" button.
2. Edit > Customize > Tools > Common Modeling Shortcut Tools > Compute Normals.

Where did you get this "Object_Combined" object from?
« Last Edit: January 30, 2019, 01:51:51 am by IStonia »

  • No avatar
  • Posts: 27
  • Vertex
January 30, 2019, 02:20:43 am
Great ok thanks!
This was made in nVil by retopoing over the reference. It looked fine in the previous version until I grabbed the latest build from you today.
Thanks for all your help, the new feature is very useful 😁
Valve Software

  • No avatar
  • Posts: 3413
  • Developer
  • Administrator
  • Polygon
January 30, 2019, 03:37:35 am
Do you still have a scene file that opens fine in previous version but no good in the new version? Looks like there is a bug and I need that file to fix it.

Edit: Never mind. It is sorted.
« Last Edit: January 30, 2019, 04:25:39 am by IStonia »

  • No avatar
  • Posts: 27
  • Vertex
February 15, 2019, 01:27:34 am
I'm having performance issues related to the automatic rewinding that's happening after every edit I make in retopo mode. As the poly count of the model increases the time it takes to rewind after transforming a component is very noticeable.
I'm having to switch back to an older build for now.
Can we get an option to disable the automatic rewinding please?
Valve Software