News:

 

Topic: FBX support  (Read 2506 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 09:05:25 am
Removing it, and the file does not import.

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon
April 19, 2017, 09:36:20 am
Try remove this also

         LayerElement:  {
            Type: "LayerElementSmoothing"
            TypedIndex: 0
         }

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 10:46:03 am
Works.  What is your train of thought? 

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon
April 19, 2017, 10:53:59 am
What we have been dealing with is the file you exported from Maya without going through Nvil.

Now here is the file which I imported from your Maya file into Nvil then exported to fbx.
http://www.digitalfossils.com/Download/FBXCreaseTest_Nvil.rar

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 11:57:32 am
Geo imports correctly, but without crease data. 

 I had a look  at it in notepad and it is without formatting so hard to read.

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon
April 19, 2017, 12:14:05 pm
Can you read any thing in it?

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 12:46:02 pm
Yeah, just doesnt have any word wrap, so is basically a single line of code.  Ahh....I can read in sublime text.
« Last Edit: April 19, 2017, 12:48:05 pm by Mason »

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon
April 19, 2017, 12:48:35 pm
It opens in my NotePad fine.

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon
April 19, 2017, 12:50:20 pm
No. It is not NotePad. Use WordPad.

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 12:58:03 pm
I found what is missing:

Seems you need this header:

; Object properties
;------------------------------------------------------------------

Objects:  {
   Geometry: 140747960, "Geometry::pCube1", "Mesh" {
      Smoothness: 3
      PreviewDivisionLevels: 2
      RenderDivisionLevels: 2
      DisplaySubdivisions: 0
      BoundaryRule: 1
      PreserveBorders: 0
      PreserveHardEdges: 0
      PropagateEdgeHardness: 0
      Vertices: *24 {

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 01:00:02 pm
These are the smooth preview settings that are needed for Creases.

Adding that to creasedCube7500_A.fbx, and it imports into Maya correctly.

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon
April 19, 2017, 01:03:23 pm
I suspect these settings too. Why Maya needs them? Do I need to set all of them?

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 01:10:26 pm
They are the smooth preview settings.  To export creases,  this preview mode has to be active (subdvisions).  I will delete each setting to see when it breaks.

FYI,  all of those settings are features Nvil already uses.
« Last Edit: April 19, 2017, 01:18:10 pm by Mason »

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 19, 2017, 01:15:27 pm
Yeah, they are needed in order to support default functionality in Maya.

Somebody would have to test with Modo/Blender to verify those apps.  They may not even support Creases in FBX regardless.

If it works correctly for Maya, it will work in Mudbox/3dsMax most likely.

  • No avatar
  • Posts: 3419
  • Developer
  • Administrator
  • Polygon