News:

 

Topic: FBX support  (Read 2678 times)

0 Members and 1 Guest are viewing this topic.

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon
April 16, 2017, 09:32:08 am
Try this. Now it's version 7.5.
http://www.digitalfossils.com/Download/NVil-Apr-16-17.rar


A couple of other issues from quick test.

1: Objects are having thier pivot rotated 90deg around Y axis.

2: When creating instance array where 2/3 axis are used to generate array, the "Instance Source" moves location within the array. For example:- Create box at world 0,0,0. Create "Instance array with 5 along X and 5 along Z. Export as FBX, then import the FBX to new scene. Although the array is in correct position, the "Instance source" is no longer at 0,0,0

1. Is the mesh's orientation still correct?
2. Should be fixed.

  • No avatar
  • Posts: 2096
  • Polygon
April 16, 2017, 03:16:45 pm
Try this. Now it's version 7.5.
How did you manage to get file version 7.5? FBX SDK 2012 will only output up to 7.2
Have you changed SDK?

Quote
1. Is the mesh's orientation still correct?
On quick tests, yes. It is the object pivot rotating 90 clockwise around Y axis
Quote
2. Should be fixed.
Now (on quick test) looks correct.

A problem with file format:-
Blender will not import the file from Nvil (it looks like blender only supports files to 7.4), so loaded the FBX(from Nvil) into "FBX converter 2013.3", but that is informing me the file is corrupted, so will not convert.

I will see if I can find an application that supports file version 7.5 (currently, I cannot test file format, as although Nvil will export/import the FBX file, that does not mean the format is currently correct)

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 16, 2017, 09:53:06 pm
On my end:

Maya --> Nvil  creases work great and orientation is correct.

Nvil --> Maya  object is smoothed and without creases,  orientation is correct.

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon
April 16, 2017, 10:08:51 pm
On my end:

Maya --> Nvil  creases work great and orientation is correct.

Nvil --> Maya  object is smoothed and without creases,  orientation is correct.


Which update did you use for the testing?

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 16, 2017, 10:53:14 pm
April 16-17  using FBX 2016

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon
April 17, 2017, 02:25:53 am
Mason, load this into Maya and see if any crease
http://www.digitalfossils.com/Download/FBXCreaseTest.rar

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 17, 2017, 09:47:07 am
Imports with crease data!!  Looks perfect.

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon
April 18, 2017, 08:33:30 am
I am still trying to pin point the problem.
Please test these two and see if the crease still there.

http://www.digitalfossils.com/Download/FBXCreaseTest - 2.rar
http://www.digitalfossils.com/Download/FBXCreaseTest - 3.rar

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 18, 2017, 11:39:33 am
I get a 404 error on the links

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 18, 2017, 12:22:19 pm
creasedCube7500_B - 2.fbx  imports into Maya correctly with crease data

B-3 does not

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon
April 18, 2017, 12:53:08 pm
You can open the two files with Windows NotePad.

The only difference between these two files is

creasedCube7500_B - 2.fbx

         EdgeCrease: *12 {
            a: 0,0.7,0.7,0,0,0,0.7,0.7,0,0,0,0
         }


creasedCube7500_B - 3.fbx

         EdgeCrease: *12 {
            a:
0,0,0.699999988079071,0,0.699999988079071,0.699999988079071,0.699999988079071,0,0,0,0,0
         }


I have no idea why creasedCube7500_B - 3.fbx doesn't work. Maybe you have better thinking. You can edit creasedCube7500_B - 3.fbx to see in what situation it works.


  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 18, 2017, 02:32:17 pm
seems your formatting was wrong!

this works:

EdgeCrease: *12 {
            a:0,0,0.699999988079071,0,0.699999988079071,0.699999988079071,0.699999988079071,0,0,0,0,0         
         }

  • No avatar
  • Posts: 288
  • Triangle
    • Portfolio
April 18, 2017, 02:37:56 pm
v3 doesnt work in Nvil either, but when correcting the formatting it also works in Nvil.

  • No avatar
  • Posts: 3475
  • Developer
  • Administrator
  • Polygon
April 18, 2017, 07:37:24 pm
Can you remove this portion and see if it still works?

      LayerElementSmoothing: 0 {
         Version: 102
         Name: ""
         MappingInformationType: "ByEdge"
         ReferenceInformationType: "Direct"
         Smoothing: *12 {
            a: 0,0,0,0,0,0,0,0,0,0,0,0
         }
      }